唐磊的个人博客

pat1009—Product of Polynomials

跟前面多项式相加解题思路一致。

This time, you are supposed to find A*B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 … NK aNK, where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, …, K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10, 0 <= NK < … < N2 < N1 <=1000.

 

Output Specification:

For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.

Sample Input

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output

3 3 3.6 2 6.0 1 1.6

通过的答案:

#include <stdio.h>
int main()
{
float array1[1001],array2[1001],array[2002];
int a,b,i,j,maxexp1=0,maxexp2=0;
int flag;
for(i = 1000,j=2000;i>=0,j>=0;i--,j--){
array1[i]=0.0f;
array2[i]=0.0f;
array[j]=0.0f;
}

scanf("%d",&a);
for(i=0;i<a;i++){
int exp = 0;
float coe = 0.0f;
scanf("%d",&exp);
scanf("%f",&coe);
if(exp>maxexp1) maxexp1=exp;
array1[exp]=coe;
}
scanf("%d",&b);
for(i=0;i<b;i++){
int exp = 0;
float coe = 0.0f;
scanf("%d",&exp);
scanf("%f",&coe);
if(exp>maxexp2) maxexp2=exp;
array2[exp]=coe;
}

for(i=0;i<=maxexp1;i++)
{
for(j=0;j<=maxexp2;j++){
array[i+j]+=array1[i]*array2[j];
}
}


int result=0;
for(i = 2000;i>=0;i--){
if(array[i] != 0)
{
result ++;
flag=i;
}
}
if(result==0)
printf("0");
else{
printf("%d ",result);
for(i=2000;i>=0;i--)
{
if(array[i]!=0)
{
printf("%d %.1f",i,array[i]);
if(i != flag) printf(" ");
}

}
}
return 0;
}
tanglei wechat
欢迎扫码加入互联网大厂内推群 & 技术交流群,一起学习、共同进步