唐磊的个人博客

pat1002-A+B for Polynomials

继续做吧。题目如下:



This time, you are supposed to find A+B where A and B are two polynomials.




Input




Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 … NK aNK, where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, …, K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10,0 <= NK < … < N2 < N1 <=1000.




Output




For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.




Sample Input



2 1 2.4 0 3.2
2 2 1.5 1 0.5



Sample Output



3 2 1.5 1 2.9 0 3.2

解题思路说明:用大数组,下标是指数,数组里面的值是系数,刚开始始终只对一部分(题意没理解清楚),在泱泱的帮助下,全部通过。代码如下:

#include <stdio.h>
int main()
{
float array[1001];
int a,b,i;
for(i = 1000;i>=0;i--){
array[i]=0.0f;
}
scanf("%d",&a);
for(i=0;i<a;i++){
int exp = 0;
float coe = 0.0f;
scanf("%d",&exp);
scanf("%f",&coe);
array[exp]=coe;
}
scanf("%d",&b);
for(i=0;i<b;i++){
int exp = 0;
float coe = 0.0f;
scanf("%d",&exp);
scanf("%f",&coe);
array[exp]+=coe;
}
int result=0,flag=0;
for(i = 1000;i>=0;i--)
{
if(array[i] != 0)
{
result++;
flag=i;
}
}
if(result == 0)
{
printf("%d",result);
return 0;
}

printf("%d ",result);
for(i = 1000;i>=0;i--)
{
if(array[i] != 0)
printf("%d %.1f",i,array[i]);
else
continue;
if(i != flag)
printf(" ");

}
return 0;
}
tanglei wechat
欢迎扫码加入互联网大厂内推群 & 技术交流群,一起学习、共同进步