唐磊的个人博客

pat1006—Sign In and Sign Out



At the beginning of every day, the first person who signs in the computer room will unlock the door, and the last one who signs out will lock the door. Given the records of signing in’s and out’s, you are supposed to find the ones who have unlocked and locked the door on that day.




Input Specification:
Each input file contains one test case. Each case contains the records for one day. The case starts with a positive integer M, which is the total number of records, followed by M lines, each in the format:



ID_number Sign_in_time Sign_out_time



where times are given in the format HH:MM:SS, and ID number is a string with no more than 15 characters.




Output Specification:




For each test case, output in one line the ID numbers of the persons who have unlocked and locked the door on that day. The two ID numbers must be separated by one space.




Note: It is guaranteed that the records are consistent. That is, the sign in time must be earlier than the sign out time for each person, and there are no two persons sign in or out at the same moment.




Sample Input:



3
CS301111 15:30:28 17:00:10
SC3021234 08:00:00 11:25:25
CS301133 21:45:00 21:58:40



Sample Output:



SC3021234 CS301133

思路是转换成秒,比较时间。代码如下:

#include <stdio.h>
#include <string.h>
#include <stdlib.h>

int gettime(char[]);
int main()
{
int n,i;
int maxtime=0,mintime=0;
char inperson[16];
char outperson[16];
char person[16];
char time1[9],time2[9];
//printf("%d",gettime("00:01:28"));
scanf("%d",&n);
maxtime=gettime("00:00:01");
mintime=gettime("23:59:59");
for(i=0;i<n;i++)
{
scanf("%s%s%s",person,time1,time2);

if(mintime>gettime(time1)){
strcpy(inperson,person);
mintime = gettime(time1);
}
if(maxtime<gettime(time2)){
strcpy(outperson,person);
maxtime = gettime(time2);
}
}
printf("%s %s",inperson,outperson);

return 0;
}

int gettime(char time[])
{

int i=0,j=0;
char t[3];
for(i=0;i<2;i++){
t[j++]=time[i];
}
t[j]='\0';
int hour = atoi(t);

for(i=3,j=0;i<5;i++){
t[j++]=time[i];
}
t[j]='\0';
int min = atoi(t);

for(i=6,j=0;i<8;i++){
t[j++]=time[i];
}
t[j]='\0';
int sec = atoi(t);

return 3600*hour+min*60+sec;
}
tanglei wechat
欢迎扫码加入互联网大厂内推群 & 技术交流群,一起学习、共同进步